Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

Bump min dep version of Qt to 5.6

parent 64c3a38a
......@@ -22,7 +22,7 @@ include(FeatureSummary)
include(GenerateExportHeader)
set(REQUIRED_QT_VERSION "5.2.0")
set(REQUIRED_QT_VERSION "5.6.0")
find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED
COMPONENTS
Core
......@@ -42,19 +42,15 @@ find_package(Qt5Designer ${REQUIRED_QT_VERSION} CONFIG QUIET)
set_package_properties(Qt5Designer PROPERTIES TYPE OPTIONAL
PURPOSE "Required to build Qt Designer plugins"
)
if(NOT Qt5Designer_VERSION VERSION_LESS 5.5.0)
find_package(Qt5UiPlugin ${REQUIRED_QT_VERSION} CONFIG QUIET)
set_package_properties(Qt5UiPlugin PROPERTIES TYPE OPTIONAL
PURPOSE "Required to build Qt Designer plugins"
)
if (Qt5UiPlugin_FOUND)
# for some reason, Qt5UiPlugin does not set its _INCLUDE_DIRS variable. Fill it manually
get_target_property(Qt5UiPlugin_INCLUDE_DIRS Qt5::UiPlugin INTERFACE_INCLUDE_DIRECTORIES)
endif()
set(DesignerPluginDeps_FOUND ${Qt5UiPlugin_FOUND})
else()
set(DesignerPluginDeps_FOUND ${Qt5Designer_FOUND})
find_package(Qt5UiPlugin ${REQUIRED_QT_VERSION} CONFIG QUIET)
set_package_properties(Qt5UiPlugin PROPERTIES TYPE OPTIONAL
PURPOSE "Required to build Qt Designer plugins"
)
if (Qt5UiPlugin_FOUND)
# for some reason, Qt5UiPlugin does not set its _INCLUDE_DIRS variable. Fill it manually
get_target_property(Qt5UiPlugin_INCLUDE_DIRS Qt5::UiPlugin INTERFACE_INCLUDE_DIRECTORIES)
endif()
set(DesignerPluginDeps_FOUND ${Qt5UiPlugin_FOUND})
set(REQUIRED_KF5_VERSION "5.7.0")
......
......@@ -22,8 +22,4 @@
#include "oktetacore.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_OKTETA_CORE, "okteta.core", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_OKTETA_CORE, "okteta.core")
#endif
......@@ -22,8 +22,4 @@
#include "oktetagui.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_OKTETA_GUI, "okteta.gui", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_OKTETA_GUI, "okteta.gui")
#endif
......@@ -22,8 +22,4 @@
#include "checksumlogging.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_OKTETA_KASTEN_CONTROLLER_CHECKSUM, "kasten.okteta.controllers.checksum", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_OKTETA_KASTEN_CONTROLLER_CHECKSUM, "kasten.okteta.controllers.checksum")
#endif
......@@ -22,8 +22,4 @@
#include "structlogging.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_KASTEN_OKTETA_CONTROLLERS_STRUCTURES, "kasten.okteta.controllers.structures", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_KASTEN_OKTETA_CONTROLLERS_STRUCTURES, "kasten.okteta.controllers.structures")
#endif
......@@ -22,8 +22,4 @@
#include "oktetakastengui.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_KASTEN_OKTETA_GUI, "kasten.okteta.gui", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_KASTEN_OKTETA_GUI, "kasten.okteta.gui")
#endif
......@@ -22,8 +22,4 @@
#include "kastencore.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_KASTEN_CORE, "kasten.core", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_KASTEN_CORE, "kasten.core")
#endif
......@@ -22,8 +22,4 @@
#include "kastengui.h"
#if QT_VERSION >= 0x050500
Q_LOGGING_CATEGORY(LOG_KASTEN_GUI, "kasten.gui", QtInfoMsg)
#else
Q_LOGGING_CATEGORY(LOG_KASTEN_GUI, "kasten.gui")
#endif
......@@ -66,21 +66,6 @@ namespace Kasten
OktetaProgram::OktetaProgram( int &argc, char* argv[] )
: mApp( argc, argv )
{
#if QT_VERSION < 0x050500
#ifndef QT_NO_DEBUG
// MSVC complains about mismatched strings... (wide vs normal)
// fix it using QT_UNICODE_LITERAL
QLoggingCategory::setFilterRules(QStringLiteral(
"okteta.core.debug = false\n"
QT_UNICODE_LITERAL("okteta.gui.debug = false\n")
QT_UNICODE_LITERAL("kasten.core.debug = false\n")
QT_UNICODE_LITERAL("kasten.gui.debug = false\n")
QT_UNICODE_LITERAL("kasten.okteta.core = false\n")
QT_UNICODE_LITERAL("kasten.okteta.gui = false\n")
QT_UNICODE_LITERAL("kasten.okteta.controllers.structures.debug = false\n")));
#endif
#endif
QApplication::setAttribute(Qt::AA_UseHighDpiPixmaps, true);
KLocalizedString::setApplicationDomain( "okteta" );
#if KCOREADDONS_VERSION >= 0x051500
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment