Commit 450c5d14 authored by Mediawiki Administrator's avatar Mediawiki Administrator
parents 6411b382 f4dc830c
This diff is collapsed.
This diff is collapsed.
<?php
/*
* This file is part of the Symfony package.
*
* (c) Fabien Potencier <fabien@symfony.com>
*
* For the full copyright and license information, please view the LICENSE
* file that was distributed with this source code.
*/
use Symfony\Component\Asset\VersionStrategy\VersionStrategyInterface;
/**
* Reads the versioned path of an asset from a JSON manifest file.
*
* For example, the manifest file might look like this:
* {
* "main.js": "main.abc123.js",
* "css/styles.css": "css/styles.555abc.css"
* }
*
* You could then ask for the version of "main.js" or "css/styles.css".
*/
class JsonManifestNetworkVersionStrategy implements VersionStrategyInterface
{
private $manifestPath;
private $manifestData;
/**
* @param string $manifestPath Absolute path to the manifest file
*/
public function __construct(string $manifestPath)
{
$this->manifestPath = $manifestPath;
}
/**
* With a manifest, we don't really know or care about what
* the version is. Instead, this returns the path to the
* versioned file.
*/
public function getVersion($path)
{
return $this->applyVersion($path);
}
public function applyVersion($path)
{
return $this->getManifestPath($path) ?: $path;
}
private function getManifestPath($path)
{
if (null === $this->manifestData) {
$fileContent = file_get_contents($this->manifestPath);
if (!$fileContent) {
throw new \RuntimeException(sprintf('Error parsing loading manifest file "%s"', $this->manifestPath));
}
$this->manifestData = json_decode($fileContent, true);
if (0 < json_last_error()) {
throw new \RuntimeException(sprintf('Error parsing JSON from asset manifest file "%s" - %s', $this->manifestPath, json_last_error_msg()));
}
}
return isset($this->manifestData[$path]) ? $this->manifestData[$path] : null;
}
}
<?php
/**
* Neverland - Modern version of MonoBook with fresh look and many usability
* improvements.
*
* Aether
* @todo document
* @file
* @ingroup Skins
*/
require_once __DIR__.'/vendor/autoload.php';
require_once 'JsonManifestNetworkStrategy.php';
use Symfony\Component\Asset\UrlPackage;
/**
* SkinTemplate class for Neverland skin
......@@ -46,8 +49,14 @@ class SkinAether extends SkinTemplate {
* @param $out OutputPage object
*/
function setupSkinUserCss( OutputPage $out ){
$out->addStyle( 'https://cdn.kde.org/aether/css/bootstrap.min.css', 'all' );
$out->addStyle( $this->stylename . '/resources/main.css', 'all' );
$urlPackage = new UrlPackage(
'https://cdn.kde.org/',
new JsonManifestNetworkVersionStrategy('https://cdn.kde.org/aether-devel/version/manifest.json')
);
$out->addStyle( $urlPackage->getUrl('aether-devel/version/bootstrap.css'), 'all' );
$out->addStyle( $urlPackage->getUrl('aether-devel/version/aether-mediawiki.css'), 'all' );
$out->addStyle( $urlPackage->getUrl('aether-devel/version/aether-sidebar.css'), 'all' );
}
/**
......
{
"require": {
"symfony/asset": "^4.3"
}
}
This diff is collapsed.
This diff is collapsed.
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment