Members of the KDE Community are recommended to subscribe to the kde-community mailing list at https://mail.kde.org/mailman/listinfo/kde-community to allow them to participate in important discussions and receive other important announcements

  • Friedrich W. H. Kossebau's avatar
    Clean-up requirements: cmake 3.0, qt 5.7, use min versions, deduplicate KF5 · bb3ab8b6
    Friedrich W. H. Kossebau authored
    Summary:
    * cmake 2.8.12 is really outdated, 3.0 is minimum in plasma & kf5
    * cmake_minimum_required should be at begin of toplevel CMakeLists.txt
    * bump qt version to 5.7, matching the min Qt version of kf5 5.42
    * with ecm being part of kf5 since early versions, share ${KF5_MIN_VERSION}
    * use QT_MIN_VERSION & KF5_MIN_VERSION also for separate find_package calls
    * deduplicate all KF5 components searched for in unconditionally included
      subdirs
    
    Test Plan: Still configures and builds with all options OFF & ON
    
    Reviewers: #kde_connect, nicolasfella
    
    Reviewed By: #kde_connect, nicolasfella
    
    Subscribers: nicolasfella
    
    Differential Revision: https://phabricator.kde.org/D11418
    bb3ab8b6
CMakeLists.txt 1.96 KB