Commit 26030115 authored by Heiko Becker's avatar Heiko Becker 🏃 Committed by Albert Vaca Cintora

Use co-installable qca-qt5 version

If both qt4 and qt5 versions of qca are present the build of the
frameworks branch tries to find Qt4 pulled in by qca and thus fails.

REVIEW: 122054
parent c7c1974e
......@@ -7,7 +7,7 @@ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${CMAKE_SOURCE_DI
find_package(Qt5 5.2 REQUIRED COMPONENTS Quick Test)
find_package(KF5 REQUIRED COMPONENTS I18n KIO Notifications ConfigWidgets DBusAddons KCMUtils IconThemes)
find_package(Qca REQUIRED)
find_package(Qca-qt5 2.1.0 REQUIRED)
include(KDEInstallDirs)
include(KDECompilerSettings)
......
......@@ -35,7 +35,7 @@ target_link_libraries(kdeconnectcore
PUBLIC
Qt5::Network
KF5::KIOCore
qca
qca-qt5
PRIVATE
Qt5::DBus
Qt5::Gui
......
......@@ -41,7 +41,7 @@ target_link_libraries( kdeconnect_sftp_config
KF5::KIOWidgets
KF5::KCMUtils
KF5::IconThemes
qca
qca-qt5
)
install(TARGETS kdeconnect_sftp_config DESTINATION ${PLUGIN_INSTALL_DIR} )
......
......@@ -8,7 +8,7 @@ set(kdeconnect_libraries
Qt5::Network
Qt5::Test
kdeconnectcore
qca
qca-qt5
)
ecm_add_test(networkpackagetests.cpp LINK_LIBRARIES ${kdeconnect_libraries})
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment