Drop outdated check for POLICY CMP0048

Using cmake_minimum_required(VERSION 3.16) ensures the pölicy exists and also is set to NEW already.

Merge request reports